POODLE SSL3

Demosphere Safe From POODLE Vulnerability

POODLE SSL3The latest in a recent string of web vulnerabilities was revealed earlier this week and Demosphere is safe!

Called POODLE, it centered around data compromised through an older SSL protocol called SSLv3.

Demosphere’s servers do not allow connections via this protocol. For end users, this issue only impacts people using older browsers like Internet Explorer version 6 and certain versions of Windows XP.

If affected, users should upgrade their operating systems and browsers to be able to connect to Demosphere’s secure registration systems.

Demosphere continues to stay up-to-date on all possible vulnerabilities to maintain secure systems.

 

Security


Kris Baker

Kris Baker is the President of Demosphere and has been serving the Youth Sports Community since 2006.